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Desain Web Dengan Macromedia Dreamwever MX 
 
 
 Macromedia Dreamwever MX dirilis pada pertengahan tahun 2002, mengantikan 
Macromedia Dremwever MX. Software in merupakan software web design yang terbesar dan 
terlengkap. Dalam mendesain web, Dreamwever menyediakan berbagai macam objek seperti 
tabel, layer, menu puldown dan rool over dad banyak lagi. 
 Disamping itu, Dreamwever MX a mendukung script server-side seperti ASP dan PHP. 
Yang paling menonjol dari Dreamwever MX adalah ketersediaan berbagai alat bantu untuk 
menciptakan script client side. Bila anda seorang pemula dalam hal script client side seperti Java 
Script, Anda tidak perlu berkecil hati. Dengan Dreamwever MX anda dapat menciptakan 
berbagai macam efek website dinamis seperti rollover image, hidden menu dan lainnya dengan 
mudah dan singkat. 
 
 

Minimum Software Requirement 
 

 Prossesor Intel Pentium II atau yang sejenis, 300 MHz 
 Sistem operasi Windows 98 / 2000 / NT(server pack 3) / ME / XP 
 RAM 98 MB (disarankan 128 MB) 
 Free disk space 275 MB 
 Microsoft Internet Explorer atau Netscape 4 
 Monitor 256 warna mampu beresolusi 800x600  

 
 

Mendesain Situs 
 
 
Sebelum Anda membuat situs, langkah pertama yang harus lakukan adalah mendesain situs Anda. 
Dengan langkah desain yang benar maka situs Anda akan terlihat lebih menarik dan banyak 
dikunjungi orang. 
 
Tentukan Tujuan Anda 
Langkah pertama adalah menentukan tujuan dari situs Anda. Tujuan akan membuat Anda fokus 
dalam membuat situs Anda. Tanyakan pada diri Anda atau user tentang situs yang akan Anda 
buat. Apa harapan yang ingin Anda dan user inginkan? 
 
Tentukan Target User Anda 
Setelah Anda menetapkan tujuan, maka Anda perlu memikirkan siapa yang akan mengunjungi 
situs Anda. Tentunya akan sangat sulit membuat situs yang kita ingin agar dapat dikunjungi oleh 
setiap orang di dunia. Hal ini disebabkan setiap orang menggunakan browser yang berbeda, 
kecepatan akses internet yang berbeda dan mungkin ada yang tidak memiliki plug in yang Anda 
gunakan. Itulah mengapa Anda perlu menentukan target user situs Anda. 
 
Kompatibilitas Browser 
Saat ini ada banyak software browser, seperti Microsoft Internet Explorer, Netscape Navigator, 
Opera dan sebagainya. Tiap-tiap browser memiliki kelebihan dan kekurangan. Hal ini tergantung 
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dari kemampuan dari masing-masing software tersebut. Tidak semua browser mendukung script 
yang ada gunakan, seperti java script, java applet, dan lain sebagainya. 
 
Organisasi Struktur Site 
Mengatur struktur site sangatlah penting untuk membuat Anda mudah membangun situs. Dengan 
struktur yang benar, maka Anda tidak akan pusing bila ingin membuat situs Anda semakin 
bertambah besar suatu hari. Untuk itu ada beberapa hal yang perlu diperhatikan dalam membuat 
struktur site, yaitu: 

1. Bagilah situs anda menjadi beberapa kategori. 
Letakkan halaman yang saling berhubungan dalam satu folder. Gunakan subfolder hanya 
bila benar-benar diperlukan. Hal ini akan membuat situs Anda mudah untuk maintenance 
dan navigasi. 

2. Tentukan dimana meletakkan item seperti image dan sound. 
Disarankan untuk meletakkan semua image, sound, applet atau yang lainnya dalam satu 
lokasi folder, sehingga saat anda ingin menambah image Anda tahu dimana letaknya yang 
tepat. 

3. Gunakan struktur yang sama untuk lokal dan remote site.  
Hal ini akan mencegah kesalahan link halaman pada saat upload. 

 
Rancanglah Desain Tampilan Halaman 
Sebelum Anda mendesain tampilan halaman situs Anda dengan menggunakan dreamwever,  
Anda perlu membuatnya terlebih dahulu dengan media lain seperti kertas atau software seperti 
Freehand, Firework, Photoshop atau yang lainnya. Akan lebih lama jika Anda bekerja dengan 
dremwever tanpa ide yang sudah jadi. 
 
Desain Navigasi 
Pada saat Anda mendesain situs, Anda juga perlu memikirkan bagaimana caranya pengunjung 
berpindah dari satu halaman ke halaman yang lain dengan mudah. Navigasi yang 
membingungkan akan membuat pengunjung menjadi malas untuk mengunjungi situs Anda lagi 
karena membutuhkan waktu yang lama untuk mencari informasi yang diinginkan. Ada beberapa 
hal yang perlu Anda ketahui untuk membuat navigas yang mudah: 

 “Anda Disini” menunjukkan bahwa pengunjung sedang berada dimana dan bagaimana 
cara menuju ke halaman berikutnya. 

 Searching dan indexes, akan membuat pengunjung dengan cepat menemukan informasi 
yang dicari. 

 Feedback, merupakan cara bagi pengunjung untuk menghubungi webmaster jika ingin 
memberikan masukan tentang situs Anda. 

 
 
 

Mengenal Tampilan Dreamwever MX 
 
 
Workspace Dreamwever MX telah mengintegrasi  semua windows dan panel dalam satu aplikasi 
window. Tampilan workspace Dremwever MX dapat dlihat pada Gambar 1. 
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Gambar 1. Workspace Dreamwever MX 
 
Welcome window menampilkan tips pada saat setting up workspace 
 
Insert Bar berisi tombol-tombol untuk menambahkan objek berupa image, table dan layer dalam 
dokumen. Tiap-tiap objek merupakan bagian dari kode HTML yang dapat diatur menurut yang 
Anda inginkan. 
 
Document toolbar berisi tombol-tombol dan menu pop-up yang menunjukkan tampilan 
document window yang berbeda(seperti Design dan Code) 
 
Standard toolbar (tidak ditampilkan dalam layout default workspace), berisi tombol-tombol 
untuk operasi umum untuk menu File dan Edit: New, Open, Save, Save All, Cut, Copy, Paste, 
Undo, Redo. Untuk menampilkan standard toolbar klik View > Toolbars > Standard 
 
Document Window menunjukkan dokumen yang sedang Anda kerjakan. 
 
Property inspector untuk melihat dan mengubah informasi dari objek yang Anda pilih. Masing-
masing objek memiliki informasi yang berbeda-beda. 
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Tag Selector dalam status bar document window bawah menunjukkan hierarki tag pilihan Anda 
dalam Design view.  
 
Panel group  merupakan panel-panel yang berhubungan yang telah dijadikan dalam satu group. 
Untuk menampilkan sebuah panel group, klik panah expander pada sisi kiri dari nama group. 
Untuk memisahkan dari panel group, drag grid pada kiri panah expander. 
 
Site Panel berfungsi untuk mengatur file dan folder yang ada dalam site Anda. 
 
 
 

Publikasi Situs 
 

Sebelum Anda mempublikasikan situs Anda dalam internet, Anda harus mendefinisikan 
situs Anda dalam lokal dan server Anda. Dahulu tugas ini dikerjakan dengan menggunakan 
software-software FTP (File Transfer Protocol), seperti WS FTP, Leap FTP, Cute FTP dan lain 
sebagainya. Sekarang Anda tidak memerlukan sofware-software tersebut. Dreamwever telah 
menyediakan program FTP di dalamnya. 
 
Dengan menggunakan panel Site, anda dapat mengatur situs anda seperti: 

 Membuat dokumen HTML 
 Melihat, membuka dan memindah file 
 Membuat folder 
 Menghapus itme 
 Transfer file melalui local sire, remote site dan melakukan testing server. 
 Mendesain navigasi situs  dengan site map. 

 
Membuat Local Site 

Local Site adalah lokasi situs dalam komputer (harddisk), yaitu tempat menyimpan file-
file situs Anda. Akan lebih baik jika Anda membuat local site terlebih dahulu sebelum membuat 
halaman web. 

 
Untuk membuat Local Site: 

1. Pilih Site > New Site. 
2. Pada kotak dialog pilih advance dan pilih kategory  Local Info. 
3. Masukkan nama situs anda pada Site Name. 
4. Pilih lokasi tempat anda meletakkan file-file situs anda pada hardisk pada kotak Local 

Root Folder. 
5. Klik OK 
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Gambar 2. Definisi Local Site 
 
Membuat Remote Site 
Remote site digunakan untuk memindahkan file-file dari Local Site ke server tempat Anda 
menghostingkan situs Anda.  
Untuk membuat Remote Site: 

1. Pilih Site > New Site. 
2. Pada kotak dialog pilih advance dan pilih kategory  Remote Info 
3. Pada Access server pilih FTP 
4. Masukkan nama server anda pada FTP Host 

Contoh: jika nama alamat situs anda www.Haomaro.com maka isikan fpt.Haomaro.com 
pada FTP Host. 

5. Tentukan nama Host Directory pada server anda. 
6. Isikan Login dan Password anda pada server anda. 
7. Tandai checkbox Firewall dan Use Passive FTP jika anda menggunakannya. 
8. Klik OK 

 



 
                  

BENGKEL INTERNET PENS-ITS                           

  
6

 
 

Gambar 3. Definisi Remote Site 
 

Mengecek Link 
Sebelum mempublikasikan situs Anda, ada baikknya Anda mengecek dahulu link-link yang ada, 
apakah link-link tersebut sudah berjalan dengan benar.  
Untuk memeriksa link: 

1. Pilih Site > Open Site 
2. Pada Panel Site pilih File > Check Links 
3. Dreamwever 

 
Mengecek Browser Target  
Selain mengecek link, Anda juga perlu mengecek browser target Anda. Apakah file yang akan 
Anda upload sudah berjalan/ditampilkan sesuai dengan yang Anda inginkan pada browser 
tertentu? 
Untuk mengecek browser target: 

1. Pilih file-file yang akan dicek atau seluruh file dalam situs Anda. 
2. Pilih File > Check Page > Check Target Browsers 
3. Pada kotak dialog yang muncul, pilih browser yang Anda inginkan. 
4. Klik Check 
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Mempublis Situs 
Setelah situs Anda siap dipublis/upload, ikuti langakah-langkah berikut: 

1. Buka situs Anda dengan menggukan Site > Open Site 
2. Pilih menu Site > Put 
3. Secara otomatis dreamwever akan mengirimkan seluruh halaman web dalam site anda 

pada server. 
 
 
 

Desain Halaman Web Dengan Tabel 
 
Tabel 
 
Tabel merupakan salah satu tool yang sangat berguna untuk mendesain halaman web. Tabel 
terdiri dari tiga bagian yaitu baris, kolom dan sel. 
 

   
 Sel  
    
   

baris 

 

kolom 
 
        
 

Gambar 4. Tabel dengan 4 baris 3 kolom 
 
Anda bisa memasukkan berbagai item seperti teks, gambar, form, applet java dan juga membuat 
tabel dalam tabel. 
Jika Anda ingin bekerja dengan tabel, maka Anda harus menggunakan Design View. 
 

Membuat Tabel 
Untuk membuat table baru: 

1. Letakkan insert point dimana Anda ingin membuat tabel 
2. Ikuti salah satu langkah berikut 

a. Dengan menggunakan Insert Bar klik tombol Table pada menu Category 
b. Pilih Insert > Table 

3. Masukkan nilai yang diminta dalam kotak dialog 
 
 
 
 
 
 
 
 
 
 
 

Gambar 5. Kotak dialog Insert Table 
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 Rows untuk menentukan jumlah baris tabel 
 Columns untuk menentukan jumlah kolom tabel 
 Cell Padding  untuk menentukan jumlah pixel antara isi dan sel tabel 
 Cell Spacing untuk menentukan jumlah pixel antar tiap tabel 
 Width untuk menentukan lebar tabel 
 Border untuk menentukan lebar border tabel. Nilai 0 (nol) berarti tidak ada border 

 
Memilih Elemen Tabel 
Untuk memilhi tabel, ikuti salah satu langkah berikut: 

 Klik pojok kiri atas tabel atau klik dimana saja pada sisi kanan atau bawah sel. 
 Klik dalam sel tabel dan pilih table tag dalam tag selector pada pojok kiri bawah 

Document Window 
 Klik sel tabel dan pilih Modify > Table > Select Table 
 Klk dalam sel tabel dan pilih Tabel Tag dalan Tag Inspector 

 
Memilih Baris atau Kolom 
Untuk memilih baris atau kolom tabel: 

1. Letakkan ponter pada sisi luar kiri baris jika Anda ingin memilih baris atau pada sisi atas 
kolom jika Anda ingin memilih kolom 

2. Saat pointer berubah menjadi gambar panah, klik baris atau kolom yang telah terpilih 
 

Memilih Sel Tunggal 
Untuk memilih sel tunggal, ikuti salah satu langkah berikut: 

 Klik dalam sel tabel, pilih tag td dalam tag selector pada pojok kiri bawah Document 
Window 

 Klik sel tabel, pilih Edit > Select All 
 

Properti Tabel 
Jika suatu tabel telah Anda pilih, pada property inspector akan menampilkan informasi yang 
berhubungan dengan tabel tersebut. 
 

 
 

Gambar 6. Property Inspector Tabel 
 

 Rows menunjukkan jumlah baris 
 Cols menunjukkan jumlah kolom 
 W menunjukkan lebar tabel 
 H menunjukkan tinggi tabel 
 CellPad menunjukkan jarak antara isi sel dan border sel 
 CellSpace menunjukkan jarak antar tiap sel 
 Align untuk meletakkan tabel di kiri, tengah atau kanan 
 Border untuk menentukan ketebalan boder 
 Tombol Clear Row Heights untuk menghapus nilai-nilai tinggi baris dan lebar kolom 
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 Tombol Convert Tabel Widths to Pixels untuk mengubah lebar tabel dari persen ke 
pixel 

 Tombol Convert Table Widths to Percent untuk mengubah lebar tabel dari pixel ke 
peren 

 Bg Color menunjukkan warna latar belakang tabel 
 Brdr Color menunjukkan warna border tabel 
 Bg Image menunjukkan gambar latar belakang tabel 

 
Layout Tabel 

Deamwever menyediakan berbagai macam layout tabel yang siap digunakan. 
Untuk memilih layout tabel: 

1. Pilih tabel kemudian pilih Commands > Format Table 
2. Pilih jenis layout tabel yang Anda inginkan. 

Tampilan kotak dialog layout tabel dapat anda lihat pada gambar 7. 
 

Menambah Baris atau Kolom 
Untuk menambah baris atau kolom: 

1. Klik sel yang ingin ditambahkan baris atau kolom 
2. Pilih Modify > Table atau klik kanan mouse kemudian pilih tabel 

 Pilih Insert Rows untuk menambah baris 
 Pilih Insert Columns untuk menambah kolom 
 Pilih Insert Rows or Columns untuk menambah baris atau kolom. Pada kotak 

dialog yang muncul pilih baris atau kolom yang ingin Anda tambah. 
 

Menghapus Baris atau Kolom 
Untuk menghapus baris atau kolom: 

1. Pilih sel dimana baris atau kolom yang ingin Anda hapus 
2. Pilih Modify > Table > Delete Row untuk mengahapus baris atau Modify > Table > 

Delete Column untuk menghapus kolom 
 
Menggabungkan Sel 
Untuk menggabungkan sel: 

1. Pilih sel-sel yang berdekatan yang ingin Anda gabungkan 
2. Pilih Modify > Tabel > Merge Cells 

 
Memecah Sel 
Untuk memecah sel: 

1. Pilih sel 
2. Pilih menu Modify > Table > Split Cell 
3. Pada kota dialog yang muncul, pilih Rows jika ingin memecah sel ke dalam baris atau 

Columns jika ingin memecah sel ke dalam kolom. 
4. Pada Number of Rows isikan jumlah baris atau kolom yang ingin dibuat dari sel tersebut. 
5. Klik OK 

 
Sorting Tabel 
Untuk melakukan sorting tabel: 

1. Pilih tabel atau sel 
2. Pilh menu Commands > Sort Table 
3. Pada kotak dialog yang muncul, pilih model sorting yang anda inginkan. 
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Gambar 7. Kotak dialog Layout Tabel 
 
 
 

Membuat Link 
 
Dreamwever menyediakan beberapa alternatif untuk membuat link ke dokumen, gambar, atau 
software lain. Untuk membuat link yang lebih menarik profesional, Anda dapat menggunakan 
image map, navagation bar atau jump menu. 
 
Link Teks 
Untuk membuat link teks: 

1. pilih teks yang akan anda pakaiuntuk link 
2. Pada kotak proerti teks,kilk tombol Browse pada bagina Link 
3. Pilh file atau alam web yang akan di-link. 

 
Untuk mengubah warna warna link teks: 

1. Pilih menu Modify > Page Properties 
2. Pada kotak Links, Visited Links dan Active Links pilih warna yang anda inginkan 

 
Link Gambar 
Untuk membuat link gambar: 

1. Pilih gambar yang akan digunakan sebagai link 
2. Pada kotak properti masukkan link yang diinginkan 
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Link ke Email 
Link email digunakan untuk mempermudah pengunjung mengirimkan email ke alamat pemilik 
email.  
Untuk membuat email link:  

1. Pilih teks atau gambar yang akan dijadikan link 
2. Pada kotak property yang muncul, pada mail to isikan alamat email 
3. Cara lain yaitu pilih menu Insert > Email Link  
4. Klik Ok 

 

 
 

Gambar 8. Kotak Dialog Insert Email Link 
 
Link Lokal 
Link lokal yaitu link yang menuju ke bagian lain dalam satu dokumen. 
Untuk membuat link ke bagian tertentu dari dokumen: 

1. Tandai bagian yang akan di-link dengan menggunakan menu Insert > Named Anchor 
2. Pada kotak dialog yang muncul, berikan nama link tersebut. 
3. Klik OK 

 
Setelah bagian dokumen selesai ditandai, kini anda dapat membuat link ke bagian dokumen 
tersebut: 

1. Pilih teks yang akan dijadikan link 
2. Pada kotak properti, ketikkan # diikuti nama anchor atau drag tombol Point to File ke 

tanda anchor  
 
Link dengan Image Map 
Image map merupakan suatu gambar yang terbagi-bagi dalam beberapa bagian, dimana setiap 
bagian tersebut memiliki link sendiri-sendiri. 
 
Untuk membuat image map: 

1. Klik image/gambar yang akan dijadikan image map 
2. Perhatikan kotak properti pada pojok kiri bawah.. 

 
Gambar 9. Image Property 
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3. Pilih salah satu dari tiga macam tombol di pojok bawah kotak properti uhtuk membuat 
map. 

 
Gambar 10. Image map link 

 
 

4. Pada kotak properti Image Map yang mincul isikan alamat yang akan di-link 
 

 
 

Gambar 11. Image Map Property 
 

5. Jika perlu isikan pada Alt nama link, yang anak muncul jika anda meletakkan mouse pada 
image map tersebut. 

 
Jump Menu 
Jump menu merupakan menu pop-up yang berisi kumpulan link. 
Untuk membuat jump menu: 

1. Pilih menu Insert > Form Object > Jump Menu 
2. Pada kotak Text isikan teks yang akan ditampilkan pada menu 
3. Pada kotak When Selectef Go To URL, isikan alamat file tujuan 
4. Pada kotak Open URLs in, pilih Main Window untuk membuka file pada jendela yang 

sama 
5. Jika perlu berikan nama pada kotak Menu Name 
6. Tandai pilihan Insert Go Button After Menu untuk menambahkan tombol Go disamping 

menu 
7. Untuk menambah menu, klik tanda + dan ulangi langkah 2 sampai 4 
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Gambar 12. Insert Jump Menu 
 
Untuk mengedit Jump menu: 

1. Aktifkan Property Inspector dengan menu Window > Properties 
2. Klik jump menu yang akan diedit. 
3. Pada Property Inspector, klik tombol List Values 

 

 
Gambar 13. Kotak dialog List Values Jump Menu. 

 
4. Setelah selesai klik OK. 

 
Flash Text 
Untuk membuat Flash Text : 

1. Letakkan pointer dimana Anda akan meletakkan flash text 
2. Ikuti salah satu langkah di bawah ini 

 Pada Insert Bar pilih Media, klik icon Flash Text 

  
 Pada Insert Bar, pilih media, drag icon Flash Text ke dalam Document Window 
 Pilih mehu Insert > Interactive Images > Flash Text 
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Gambar 14. kotak dialog Insert Flash Text 

 
3. Pilih model huruf pada Font dan ukuran huruf pada Size 
4. Pada menu Color pilih warna yang anda inginkan 
5. Pada Rollover Color pili h warna yang anda inginkanpada saat rollover 
6. Masukkan teks link pada text field 
7. Isikan nama file yang akan di-link pada kotak Link 
8. Pilih warna latar belakang yang sesuai pada Bg Color 
9. Pada kotak Save As isikan nama file 
10. Klik OK 

 
Flash Button 
Untuk membuat Flash Text : 

1. Letakkan pointer dimana anda akan meletakkan flash text 
2. Ikuti salah satulangakah dibawah ini 

 Pada Insert Bar pilih Media, klik icon Flash Button 

  
 Pada Insert Bar, pilih media, drag icon Flash Button ke dalam Document Window 
 Pilih menu Insert > Interactive Images > Flash Button 
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Gambar 16. Kotak Dialog Insert Flash Button 
 

3. Pilih model tombol pada Style 
4. Pada kotak Button Text isikan nama tombol yang akan ditampilkan 
5. Pilih model huruf pada Font dan ukurannya pada Size 
6. Isikan nama file yang akan di-link pada kotak Link 
7. Pilih warna latar belakang yang sesuai pada Bg Color 
8. Pada kotak Save As isikan nama file 
9. Klik OK 

 
 
 
 
 
 
 
 


